» Willkommen auf Software «

Mythilos
aus Jena
offline



OC God
18 Jahre dabei !


Folgender Ausgangspunkt:

Eine Excel-Datei mit vielen Tabellenblättern.
In einem Sheet(ich sag jetzt mal Ausgabesheet dazu) lasse ich mir entsprechende Bezüge von anderen Sheets anzeigen. Und zwar sind das 9 SPalten á 14 Zeilen. Ich möchte eine 15. Zeile hinzufügen, da ich in dem Ausgabesheet ein weites "Feature" anzeigen lassen möchte welches aus den Ausgabedaten errechnet wird.
Dazu erstelle ich in einem neuen Sheet einen Bezug zu den ausgegebenen Daten in dem Ausgabesheet.
In diesem neuen Sheet möchte ich mit diesen Daten rechnen und dann auch dieses Ergebnis im Ausgabesheet anzeigen lassen.

Das Problem besteht in dem neuen Sheet.
Alle Rechnungen und Bezüge stehen und werden entsprechend angezeigt. (Ich kann bestimmte Voraussetzungen im Ausgabefenster angeben und dann verändern sich eben diese Ausgaben entsprechend ..durch den Zellenbezug)

Das Problem:
Ich muß, um die Rechnungen durchführen zu können, die ausgegebenen Daten der Bezüge (Zahlen) sortieren.
D.h. wenn ich eine Voraussetzung verändere ändern sich auch die Ergebnisse. Diese Ergebnisse werden dann automatisch in dem neuen Sheet angezeigt und müssen dann automatisch Sortiert werden um weiter verrechnet werden zu können.


Das Grundproblem:
automatisches Sortieren auch nach geänderten Bezügen

Ist es möglich das Problem logisch mit Formeln anzugehen?


Japanese scientists have created a camera with such a fast shutter speed, thy now can photograph a woman with her mouth shut!

Beiträge gesamt: 1617 | Durchschnitt: 0 Postings pro Tag
Registrierung: März 2003 | Dabei seit: 6727 Tagen | Erstellt: 14:13 am 9. Nov. 2009
OberstHorst
aus Taunusstein
offline



OC God
13 Jahre dabei !

Intel Core i7
2800 MHz


Glaube, dass das höchstens über ne verschachtelte "Wenn" abfrage in verbindung mit ner "Rang" Abfrage geht.

=WENN(RANG(A1;$A$1:$A$14;WAHR)=1;A2;WENN(RANG(A2;$A$1:$A$14;WAHR)=1;A3;WENN(RANG(A3;$A$1:$A$14;WAHR)=1;A3;"...")))

Hier gleichst du den Rang einer Nummer in einer Matrix ab. In der ersten Spalte fragst du nach der Rangnummer 1 ab. Wenn das passt, gibst du dich selber zurück, wenn nicht, fragst du die nächste Zeile nach dem Rang 1 ab usw...

Alternativ kannst du den Rang links neben den Zahlen anzeigen lassen. Dann einfach mit nem Verweis nach der 1 suchen und eine Spalte nach rechts gehen:

in der Spalte B stehen dann deine Werte
in A1 steht =RANG(B1;$B$1:$B$14;WAHR)
in A2 steht =RANG(B2;$B$1:$B$14;WAHR)
usw....

Dann schreibst du zB in b16 b17 usw:
=SVERWEIS(1;$A$1:$B$14;2;FALSCH)
=SVERWEIS(2;$A$1:$B$14;2;FALSCH)
=SVERWEIS(3;$A$1:$B$14;2;FALSCH)
=SVERWEIS(4;$A$1:$B$14;2;FALSCH)
usw...

Ich weiß natürlich nicht, wie weit du Spalten hinzufügen kannst, aber das wäre imo die beste Lösung.


<-- Killerspielespieler
Geh doch zum MediaMarkt und lass dich da beraten...

Beiträge gesamt: 6824 | Durchschnitt: 1 Postings pro Tag
Registrierung: Nov. 2007 | Dabei seit: 5006 Tagen | Erstellt: 16:34 am 9. Nov. 2009
Mythilos
aus Jena
offline



OC God
18 Jahre dabei !


ok..das könnte klappen! Ich hab immer 14Zeilen die ich sortieren muß...also 14Ränge!


Japanese scientists have created a camera with such a fast shutter speed, thy now can photograph a woman with her mouth shut!

Beiträge gesamt: 1617 | Durchschnitt: 0 Postings pro Tag
Registrierung: März 2003 | Dabei seit: 6727 Tagen | Erstellt: 16:39 am 9. Nov. 2009
Mythilos
aus Jena
offline



OC God
18 Jahre dabei !


irgendwie pack ich das nicht...
hier mal ein Beispiel(es geht bei den zu sortierenden Zellen um den Zellbereich K8:K21):
da werden solche Werte durch einen Tabellenblattbezug angegeben:

0,0495
0,0355
0,0370
0,0370
0,0270
0,0255
0,0220
0,0350
0,0210
0,0405
0,0380
0,0555
0,0235
0,0385

Ich hatte das jetzt mit den ersten Zellen mit folgender Formel versucht, was aber nicht geklappt hat.
=WENN(RANG(K8;$K$8:$k$21;WAHR)=1;k9;WENN(RANG(k9;$K$8:$k$21;WAHR)=2;k10;WENN(RANG(k10;$K$8:$k$21;WAHR)=3;k11;WENN(RANG(k11;$K$8:$k$21;WAHR)=4))))


irgendwo hab ich hier ein logisches Problem drin ...

Ein weiteres Problem wird dann auch ersichtlich:
Es gibt teilweise die selben Zahlen!
Da ich dann an anderer Stelle eine Rangabfolge abrufe und da deren Werte erscheinen lassen will wirds schwer, weil er wahrscheinlich nicht weiß, welchen der (z.B. beiden 0,025) Werte er nehmen soll.


(Geändert von Mythilos um 19:57 am Nov. 9, 2009)


Japanese scientists have created a camera with such a fast shutter speed, thy now can photograph a woman with her mouth shut!

Beiträge gesamt: 1617 | Durchschnitt: 0 Postings pro Tag
Registrierung: März 2003 | Dabei seit: 6727 Tagen | Erstellt: 19:46 am 9. Nov. 2009
Mythilos
aus Jena
offline



OC God
18 Jahre dabei !


=WENN(K8="";"";RANG(K8;K$8:K$21;0))

damit habe ich Ränge hin bekommen!

nun gehts weiter im Text... Sortieren...


Japanese scientists have created a camera with such a fast shutter speed, thy now can photograph a woman with her mouth shut!

Beiträge gesamt: 1617 | Durchschnitt: 0 Postings pro Tag
Registrierung: März 2003 | Dabei seit: 6727 Tagen | Erstellt: 20:05 am 9. Nov. 2009
Mythilos
aus Jena
offline



OC God
18 Jahre dabei !


ich habs hin bekommen!
Daten stehen in K8:K21
erste nebenstehende Spalte (Ränge bilden):
=WENN(K8="";"";RANG(K8;K$8:K$21;0)+ZEILE(J8)%%)

zweite nebenstehende Spalte (Ränge sortieren):
=WENN(ZEILE(A1)>ANZAHL(L$8:L$21);"";KKLEINSTE(L$8:L$21;ZEILE(A1)))

dritte nebenstehende Spalte (und letztlich die mit den sortierten Werten):
=WENN($M8="";"";INDEX(K$8:K$21;VERGLEICH($M8;$L$8:$L$21;0)))


Japanese scientists have created a camera with such a fast shutter speed, thy now can photograph a woman with her mouth shut!

Beiträge gesamt: 1617 | Durchschnitt: 0 Postings pro Tag
Registrierung: März 2003 | Dabei seit: 6727 Tagen | Erstellt: 21:00 am 9. Nov. 2009
OberstHorst
aus Taunusstein
offline



OC God
13 Jahre dabei !

Intel Core i7
2800 MHz


Aja.. wenns klappt, ist das ja gut ;)

Mein Ansatz wäre jetzt einfach die Ränge in Spalte J daneben schreiben und dann mit nem sverweis entsprechend zu suchen.

Die Formel, die bei dir nicht funktioniert hat wäre folgende:

=WENN(RANG(K8;$K$8:$k$21;WAHR)=1;k8;
WENN(RANG(k9;$K$8:$k$21;WAHR)=1;k9;
WENN(RANG(k10;$K$8:$k$21;WAHR)=1;k10;
WENN(RANG(k11;$K$8:$k$21;WAHR)=1;k11;
WENN(RANG(k12;$K$8:$k$21;WAHR)=1;k12;
WENN(RANG(k13;$K$8:$k$21;WAHR)=1;k13;
WENN(RANG(k14;$K$8:$k$21;WAHR)=1;k14;
WENN(RANG(k15;$K$8:$k$21;WAHR)=1;k15;
WENN(RANG(k16;$K$8:$k$21;WAHR)=1;k16;
WENN(RANG(k17;$K$8:$k$21;WAHR)=1;k17;
WENN(RANG(k18;$K$8:$k$21;WAHR)=1;k18;
WENN(RANG(k19;$K$8:$k$21;WAHR)=1;k19;
WENN(RANG(k20;$K$8:$k$21;WAHR)=1;k20;
WENN(RANG(k21;$K$8:$k$21;WAHR)=1;k21; "Fehler"
))))))))))))))

Ist zwar nicht die hübscheste Lösung, aber sie hätte (vielleicht) auch funktioniert :lol:


<-- Killerspielespieler
Geh doch zum MediaMarkt und lass dich da beraten...

Beiträge gesamt: 6824 | Durchschnitt: 1 Postings pro Tag
Registrierung: Nov. 2007 | Dabei seit: 5006 Tagen | Erstellt: 21:35 am 9. Nov. 2009