» Willkommen auf Notebook «

Digixp
offline


OC Newbie
16 Jahre dabei !


Jeder kennt es, man will günstig ein SlimLaufwerk nachrüsten, ob jetzt Brenner, DVD oder gar Combo, dann merkt man, das es im Bios nicht erkannt wird, aber unter Windows. Der Grund liegt daran, das es fest auf Master, Slave oder Cable-Select geflasht ist und nicht via Jumper geändert werden kann wie bei den grossen Laufwerken

Ich erkläre am Beispiel eines QSI SDR-081 DVD-Laufwerkes wie man es umflasht, das es im Bios erkannt wird, da man sonst von keiner CD oder DVD booten kann. ICh musste zB. von Cable-Select auf Master umflashen.
Man braucht: Eine Bootdiskette ohne Autoexec.bat und Config.sys(wie beim Bios), das Flashprogramm für das Laufwerk und die Firmwaredatei. Und AIDA16(die DOS-Variante) zum ermitteln des Portes(Primary und Secondary)

Den Laptop von der Diskette starten und das Flashutility starten(bei mir QFSDR081.EXE), dann sieht man alle möglichen Parameter:

Code
SDR081 Series DVD-ROM Firmware Utility v6.60
Copyright reserved : Quanta Storage Inc.
Author             : Simeon Chu
usage: QFSDR081 [port] [/Tx] [/Q] [/Ffilename] <CR>
where  IDE port: 1 = 1st master, 2 = 1st slave, 3 = 2nd master, 4 = 2nd slave
                * no setting stands for auto search
           /Tx: change drive IDE configuration
                x = M: Master
                    S: Slave
                    C: Cable select
                    R: Reverse Cable select
            /Q: quiet mode (no beep after flash complete)


Ich gebe dann A:\QFSDR081 /TM /Femr6.bin ein um das Laufwerk in den Mastermodus zu bekommen. Den IDE-Port(wird automatisch ermittelt) und den Quietmodus lassen wir absichtlich weg. Nach erfolgreichem Flashprogramm muss der Laptop ausgeschaltet werden. Wenn nach dem neuanschalten das Laufwerk im POST erscheint, ist alles Palletti. Wenn nicht, muss mit AIDA16 ermittelt werden an welchem IDE-Port,also zB. Secondary/Slave das Laufwerk hängt. Dann nochmal das Flashutility mit der Angabe des IDE-Ports und den vorherigen Parameter starten, danach Laptop wieder aus und dann einschalten. Dann sollte es funktioniert haben.

Viel Glück dabei.
DIGIXP

Beiträge gesamt: 1 | Durchschnitt: 0 Postings pro Tag
Registrierung: Jan. 2003 | Dabei seit: 6132 Tagen | Erstellt: 18:21 am 12. Jan. 2005