On/Off for the Ultra IR USB

- OCinside.de PC Forum

-- English

--- On/Off for the Ultra IR USB

Ein Ausdruck des Beitrags mit 6 Antworten ergibt bei 3 Antworten pro Seite ca. 2 DIN A4 Seiten. Das entspricht bei 80 g/m² ca. 9.98 Gramm Papier.

-- Veröffentlicht durch ocinside am 16:45 am 20. Nov. 2008

Nice to read that it's now working fine :thumb:

BTW. The intention of the fanshop is not to sell finished assembled products.
I like to give visitors the guidances and (if necessary) the kits to build things like infrared receiver, displays and so on.
I know, that not all visitors have solder experiences, but this is one more reason to give them the chance to build these nice things on their own :thumb:

-- Veröffentlicht durch kidproquo am 9:51 am 16. Nov. 2008

Fixed it!

I attached an LED to pins 5 and 4 and saw no output. Checked the circuit and saw that Pin 1 was grounded. Fixed that and saw the LED light up when the power button was pressed on the remote. Hooked it up to the PC and it worked after switching the polarity.

Thanks for your support. You do have a great product! Why don't you offer an assembled version?

-- Veröffentlicht durch ocinside am 20:43 am 12. Nov. 2008

Of course you don't need a LED and it's not necessary to measure something.
But it makes things easier for you ;)
Pressing several remote control buttons to check if they are RC5 and working while holding the multimeter and looking to the multimeter display to check if it has ~5V for about 1 second ... a LED would be easier ;)
OK, but as written before, you don't have to check voltages - just connect it to the PC.
Believe me, I guess it's 90 percent the tested remote control code, 9.99999 percent a solder failure and 0.00001 percent another thing - so just try a few (or all) Philips TV codes.

BTW. this IC doesn't need a quartz, because the fuse bit is set for the internal RC oscillator.

-- Veröffentlicht durch kidproquo am 15:54 am 12. Nov. 2008

Thanks for the reply.

I have tried changing polarities at the opto-coupler cable and still no switching :-(

I made a mistake in the posting. I did actually check voltage between Pins 5 and 4 of the ATtiny13V-10PU and saw nothing except 110-160mV. I do not have an LED, but do I need it? Can't I just use a multimeter and check voltage between Pins 5 and 4 while I send an IR signal? All I read is 110-160mv between pins 5 and 4.

I think I have an RC5 remote since I am able use it to control the PC i.e the tiny45 part is working and I am getting IR commands. The same remote does not do any on/off switching.

An unrelated question - why don't we need the quartz clock to be connected to the ATtiny13V-10PU? Sorry if that sounds dumb. Just curious.

-- Veröffentlicht durch ocinside am 7:09 am 12. Nov. 2008

Make sure, that you're using RC5 signals.
Use an universal remote control and set it to a RC5 device.
E.g. several Philips TVs are using RC5 signals, so program one of these codes to your universal remote.

And try the power switch cable from the opto coupler in both directions.
Or you can test the power on/off function with a low current LED between pin4 (GND) and pin5 (or pin3) to see if you receive a correct RC5 signal from your remote.
Pin1 is not the right point to check the voltage.

-- Veröffentlicht durch kidproquo am 4:35 am 12. Nov. 2008


I get the IR part working but the ON/OFF does not work. I have checked all connections to the ATtiny13V-10PU (pins 1, 8, 4, 5, 6 and 7) and it looks to be fine. But I checked the voltage between Pin 5 and Pin 1 with the jumper installed (which grounds Pin 6) and pressing a key on the remote. The voltage is always 110-160 mV, never changes. Shouldn't it be some higher voltage which is sent to the opto-coupler?


OCinside.de PC Forum
© 2001 - 2019 www.ocinside.de