Username:   Not registered yet?
Password:   Forgot password?
iB Code Einmal klicken um den Tag zu öffnen, nochmal klicken zum Close

Top Smilies

HTML ist on für dieses Forum

IkonCode ist on für dieses Forum



Would you like to add your signature?
Do you want to be informed about answer by email?
Do you want to activate emoticons in your post?

Review of postings for No power with USB Ultra IR receiver? (the latest posts first)
DrJones Erstellt: 8:49 am 19. Mai 2008
Hmmm, I don't have any standard LEDs handy... these are all I've got (picked up a bunch from a HK supplier, like US$25 for 700).  I'll see about just snipping out LED1 (the one next to the optocoupler) and give that a shot.  Although I've tested the LEDs to work on as little as 15mA, since they are high brightness LEDs I suppose it's possible that this one is sinking enough current that the optocoupler doesn't work?

If cutting the first one doesn't get me anywhere I'll go ahead and try removing LED2 as well, but it does seem to work right now (it flashes a few times when I press any remote button for any device... when I use my Logitech Harmony to turn everything on/off at once it goes nuts!).  Could it be causing problems even if it appears to be blinking properly?

Thanks again for your help!  I love learning, and it's great to have someone to help me along the way ^_^
ocinside Erstellt: 8:41 am 19. Mai 2008
Looks very nice, except the two LEDs.
Because they look like bright/ultrabright LED and doesn't look like a low current LED.
This could be the reason, why your Power on/off function doesn't work.
Because it's possible that the Tiny13 IC doesn't get a capable signal from the TSOP and/or the optocoupler doesn't get enough power from the Tiny13 IC (or in the worst case damage the IC output).

So in the first step I would suggest, that you replace the bottom LED with an usual (non-bright) or best with a low current LED.
If you like to use an usual LED, you should connect it in row with the resistor between pin4 (GND) and pin3 (second signal output ) of the Tiny13 IC.
If this still doesn't work, you should also remove the bright LED at the TSOP1738.
DrJones Erstellt: 3:04 am 19. Mai 2008
Here you go... shown are the 512x384 thumbnails.  Use a link to view the larger versions; I've posted both the untouched pictures and pictures with numbers added so it's easier to coordinate the holes and components.  I've got a list of components at the bottom as well.

Thanks for your help!

1024x768 (with numbers)
2048x1536 (with numbers)

1024x768 (with numbers)
2048x1536 (with numbers)

1,2: Qz1
3-10: AT90S 2323-10
11-18: AT90S 2343
19,20: Jumper wire
21,24: Jumper wire
22,23: R3 - 2x ~190<font face="Symbol">W</font> in series
25,26+: LED1
27,28: Jumper wire
29,30: R2 - 390<font face="Symbol">W</font>
31,32: J3
33,34+: C1
35: DATA+
36: DATA-
37,38: Jumper wire
39,40: R1 - 1.5k<font face="Symbol">W</font>
41,42: C2 (marked C3 on LED schematic?)
43-48: CNY17-2
49+,50: LED2
51,52: R4 - 2x ~190<font face="Symbol">W</font> in series
53: VCC
54: GND
55-57: TSOP 1738
58,59: Power Switch
ocinside Erstellt: 19:31 am 18. Mai 2008
There're a few reasons for this problem.
If you've already tried several philips remote codes and if you've soldered the low current LED with approx. 390 Ohm - 1K resistor to these pins (depends on the LED used), it should light up on the second remote signal.
First of all I would suggest, that you mail or post a picture of the upper and bottom PCB surface with activated macro function.
(with "macro function" I mean the flower symbol on your digital camera).
DrJones Erstellt: 3:51 am 18. Mai 2008
I installed LEDs on my circuit so I could test without the driver (mainly the power circuit), but I'm not getting anywhere...

I have a red LED hooked up alongside the receiver (TSOP 1738), and a green LED hooked up alongside the optocoupler (CNY17-2).  When I press buttons on any remote, the red LED blinks, which I would assume is a good indicator that the device has power and that it's receiving IR signals.  However, even when I program my universal remotes to any of the provided Philips codes, the green LED never blinks and my computer never turns off.

I assume that even if I had something hooked up wrong to the computer's power button, the green LED should blink (since it's hooked up on the "inside" of the optocoupler)?  I currently have the anode (positive) of the LED connected to pin 1 of the optocoupler and the cathode to pin 2... that's correct, right?

Any ideas?